Tag


Apabila kita berlangganan internet biasanya Provider Internet (ISP) mempunyai sebuah layanan untuk memisahkan jalur atau gateway antara koneksi internet Internasional dan OpenIXP. Dengan cara ini para customer dapat dengan mudah untuk melakukan management bandwith untuk akses kedua jalur tersebut. Biasanya metode yang sering digunakan adalah dengan BGP Peer.

BGP (Border Gateway Protocol) adalah salah satu jenis protokol routing yang berfungsi untuk mempertukarkan informasi antar Autonomous System (AS). BGP ini merupakan sebuah Dinamic Routing dan pada mikrotik sendiri terdapat beberapa macam fitur dinamic routing selain BGP seperti OSPF dan RIP. Untuk pertukaran informasi BGP ini memanfaatkan protokol TCP sehingga tidak perlu lagi menggunakan protokol jenis lain untuk mengangani fragmentasi, retransmisi, acknowledgement dan sequencing.

[Study Case] Pemisahan Jalur Koneksi Internasioanl dan IIX (lokal) dengan BGP Peer.

Agar bisa mengetahui mengenai BGP lebih jauh lagi, kita akan langsung mencoba praktek konfigurasi BGP. Untuk percobaan kali ini kita akan memisahkan jalur dari koneksi internet Internasioanal dan IIX (lokal). Misal kita berlangganan internet pada sebuah ISP dengan layanan BGP Peer. Dengan contoh topologi seperti pada gambar berikut.

Kita memiliki 2 buah link ke internet yaitu IIX dan Internasional yang menggunakan IP Local (172.16.1.2/30 dan 172.16.4.2/30) dengan satu link client local (192.168.88.0/24) dan satu link untuk server (menggunakan IP Public 202.73.XXX.11/30). Nah, masing-masing IP Address tersebut kita tambahkan pada interface router seperti pada topologi diatas.

Semua IP Address ini hanya sekedar permisalan (dummy), jadi bisa disesuaikan dengan kondisi real implementasi di lapangan.

 

Konfigurasi BGP

Setelah kita tambahkan IP Address tersebut pada router, selanjutnya kita akan konfigurasi pada menu BGP. Kita pilih pada menu Routing -> BGP.

Pada tab ‘Instance’ kita tentukan nilai dari paramter AS (Autonomus System Number). Kita bisa tambahkan satu profile intsance baru atau kita juga bisa mengubah konfigurasi pada profile yang telah ada (default). Nilai dari ASN ini kita sesuaikan dengan informasi dari ISP. Sebagai contoh disini kita menggunakan 65432.

Kemudian kita juga akan melakukan konfigurasi pada tab ‘Peers’. Disini kita akan menambahkan dua buah rule untuk peering (memasangkan) dengan BGP Router yang ada di ISP. Kita tambahkan peering untuk link koneksi Internasional dan juga IIX (lokal).

Pada parameter name kita tentukan nama dari jenis koneksi tersebut (Internasional dan IIX). Kemudian kita arahkan parameter instance ke profile yang telah kita buat sebelumnya yaitu ‘default’. Untuk ‘Remote Address’ adalah gateway dari masing-masing link koneksi, Jangan lupa untuk menentukan ‘Remote AS’. Hal ini juga disesuaikan dengan informasi dari ISP. Sebagai contoh kita kali ini kita menggunakan 65530.

Apabila proses ‘peering‘ berhasil maka pada kolom state akan mucul keterangan ‘Established‘ dan jika kita melihat melalui New terminal dengan script /routing bgp peer print, maka pada dua rule yang kita buat tadi terdapat flag ‘E‘.

Dan apabila kita lihat pada menu IP ->Routes maka akan muncul banyak sekali rule routing dengan flag ‘DAb‘ (Dynamic Active BGP) yang mana rule tersebut merupakan rule untuk destination dari IIX (lokal) dan juga Internasional.

Sampai langkah ini IP Public yang ada pada router kita sudah bisa diakses dari luar. Namun, untuk koneksi internetnya sendiri dari router maupun LAN (client) masih belum bisa diakses. Untuk itu kita akan menambahkan rule pada firewall NAT. Namun disini kita tidak akan menggunakan rule NAT dengan “action=masquerade“, karena link yang menuju ke internet yaitu ether1 dan ether2 menggunakan IP Private. Sehingga kita akan menggunakan “action=src-nat” dengan menunjuk IP Public yang berada pada salah satu interface router yaitu di ether5.

Pertama, kita tambahkan NAT untuk dua link koneksi ke internet (Internasional dan IIX). Contoh scriptnya adalah sebagai berikut:

/ip firewall nat
add action=src-nat chain=srcnat out-interface=ether1 src-address=172.16.1.2 to-addresses=202.73.xxx.11
add action=src-nat chain=srcnat out-interface=ether2 src-address=172.16.4.2 to-addresses=202.73.xxx.11

Kedua, kita tambahkan NAT untuk akses internet dari jaringan LAN. Contoh scriptnya adalah sebagai berikut:

/ip firewall nat
add action=src-nat chain=srcnat src-address=192.168.88.0/24 to-addresses=202.73.xxx.11

Dari langkah ini seharusnya client maupun router sudah bisa koneksi ke internet. Kita bisa melakukan traceroute atau test ping untuk pengecekan. Nah, demikianlah langkah-langkah bagaimana cara konfigurasi dasar dari BGP. Anda bisa sesuaikan alokasi ip addressing sesuai dengan kondisi real pada jaringan Anda.