Tag

,


Pada artikel kali ini kita akan membahas tentang OpenVPN yang ada di Mikrotik dan bagaimana cara melakukan konfigurasinya. Dalam banyak topik dan forum dimana para pengguna Mikrotik membicarakan tentang OpenVPN dan rata-rata hampir 90% mereka memiliki kendala dalam menjalankan atau bagaimana melakukan instalasi OpenVPN yang benar.

Apakah itu OpenVPN ?

OpenVPN merupakan salah satu tipe VPN untuk interkoneksi jaringan lokal yang memanfaatkan jaringan public (WAN/Internet) dengan komunikasi yang bersifat secure. VPN ini biasa digunakan ketika dibutuhkan keamanan data yang tinggi.Secara default, OpenVPN menggunakan UDP port 1194 dan dibutuhkan certificate pada masing-masing perangkat untuk bisa terkoneksi. Untuk client compatibility, OpenVPN bisa dibangun hampir pada semua Operating System dengan bantuan aplikasi pihak ketiga. OpenVPN menggunakan algoritma sha1 dan md5 untuk proses autentikasi, dan menggunakan beberapa chiper yaitu blowfish128, aes128, aes192 dan aes256. Trafik yang melewati tunnel OpenVPN akan mengalami overhead ± 16%.

Konfigurasi OpenVPN

Untuk contoh kasus, kita akan mencoba menghubungkan dua network menggunakan OpenVPN. Masing-masing network memiliki 1 buah router untuk gateway utama.

Pertama, untuk meningkatkan keamanan dari koneksi OpenVPN ini, kita akan menambahkan sertifikat pada server dan juga client. Langkah-langkah pembuatan sertifikat bisa dilihat di artikel sebelumnya disini.

Setelah kita membuat sertifikat, kita akan mengaktifkan terlebih dahulu OpenVPN Server pada router gateway utama di ‘Kantor A‘. Pilih menu PPP → pada Tab Interface klik pada tombol Command OVPN Server. Kemudian untuk mengaktifkan OpenVPN Server centang opsi Enabled. Kita tambahkan juga sertifikat untuk koneksi OpenVPN di ‘Kantor A‘ sebagai OVPN Server pada parameter ‘Certificate‘ seperti tampilan berikut.

Sebagaimana koneksi VPN yang lain kita juga akan membuat ‘PPP secret‘ untuk dial koneksi dari OVPN Client. Konfigurasi dari PPP Secret adalah seperti tampilan berikut. <palign=”justify”>

<palign=”justify”>
<palign=”justify”>

<palign=”justify”>

Untuk lebih memudahkan dalam improvisasi setting, pada OpenVPN Server kita akan membuat sebuah interface static untuk OpenVPN secara manual. Sebenarnya apabila kita tidak membuat interface tersebut, router akan membuat interface OpenVPN secara dinamic oleh router pada saat koneksi OpenVPN terbentuk. Namun interface tersebut akan hilang jika koneksi terputus.

<palign=”justify”> Adapun cara membuatnya pilih menu PPPInterfacesAdd [ + ] →  OpenVPN Server Binding. Dan isikan pada parameter yang dibutuhkan sesuai tampilan gambar berikut. Untuk parameter ‘User‘ isikan sesuai dengan nama di PPP Secret yang telah kita buat.
<palign=”justify”>

<palign=”justify”>

<palign=”justify”>
<palign=”justify”>

<palign=”justify”>

<palign=”justify”>

Selanjutnya kita akan melakukan konfigurasi untuk ‘Kantor B‘ sebagai OpenVPN Client. Kita pilih pada menu PPPInterfacesAdd [ + ] →  OVPN Client. Kemudian isikan masing-masing parameter seperti pada tampilan berikut.

<palign=”justify”>

<palign=”justify”>
<palign=”justify”>

<palign=”justify”>

Apabila OpenVPN berhasil terkoneksi maka kita bisa melihat pada router OpenVPN Server di menu PPPActive Conections. Disitu akan tertampil informasi dari perangkat client yang berhasil terkoneksi ke OpenVPN Server.

<palign=”justify”>
<palign=”justify”>

<palign=”justify”>

Kemudian untuk menghubungkan LAN antara ‘Kantor A‘ dan ‘Kantor B‘ melalui koneksi OpenVPN, kita bisa menambahkan pengaturan routing. Seperti pada gambar topologi diatas diketahui bahwa  LAN untuk ‘Kantor A‘ adalah 172.16.1.1/24 dan untuk ‘Kantor B‘ adalah 172.31.1.1/24. Contoh rule routingnya adalah sebagai berikut:

KANTOR A
/ip route
add distance=1 dst-address=172.31.1.0/24 gateway=openVPN

<palign=”justify”>

KANTOR B
/ip route
add distance=1 dst-address=172.16.1.0/24 gateway=ovpn-out